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The purpose of this workshop is to get you started and to have fun with
MATLAB!

Let’s talk a little and decide on what we will be covering today.

WHY MATLAB?

WHAT MATLAB IS NOT.
SETTING THE TOOL.:
MATRIX OPERATIONS:
XY PLOTS IN MATLAB
IMPORTING DATA:
SIMULINK:
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e WHY MATLAB?

» MATLAB is relatively easy to learn

* MATLAB code is optimized to be relatively quick when performing
matrix operations

* MATLAB may behave like a calculator or as a programming
language

« MATLAB is interpreted, errors are easier to fix.

e WHAT MATLAB IS NOT.

Limitations of MATLAB

« MATLAB is NOT a general purpose programming language.

« MATLAB is an interpreted language (making it for the most part
slower than a compiled language such as C++)

« MATLAB is designed for scientific computation and is not suitable
for some things (such as parsing text).
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SETTING THE TOOL :
Open MATLAB:

<} MATLAB
File Edit Wiew wWeb Window Help

0@ | % B2 @ o oo | 8| 2 | CurentDirectory: | CmATLABSpSWork ¥I[J

Command YWindow:

Eq' [ﬁ | @ | ﬁ Stack |Dase
This is a Classroom License for instructional us

Name dize Bytes Class Research and commercial use is prohibited.

Uzing Toolbox Path Cache. Type "help toolbox_path

To get started, select "MATLAE Help™ from the Help

»>= demo
=
Warkspace I Current Directory I
Command History
polelg) ot
Zerog)
narginig)
wargin(-o)
Goor=-10*%loglOfalpha)
Gc
-- 3/22/04 12:30 MM --%
open|'C:3EE4343 5320%projecthjgsin. mdl')
%-- 3/26/04 4:58 PM --%
demao
W

< i > < >
4\ Start
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File Edit
D& &

simple

v Command Windoe
aTL Short Histary

#\ Coun ¥ Command History

. Tall Histany
¥ Current Directo —
#cont e Five Panel
o\ curw ¥ YWaorkspace
#\Data ¥ Launch Pad
Help
Current Directory Filter *

" | La Wiarkspace Wiew Options r

mtt

4| M| command Histary [ currentDi| | 4| |

Ready
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<) MATLAB M[=] E3
Ei[}5 Edit iew Meb MWindow Help
0 E’,‘:| ¥ B o o | i | ? |Current Directary: [ o wia TLABE Y ork =l
Y
To get started, select "MATLAE Help™ from the Help menu. I
o
I~
1 N

Ready
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k) MATLAB
File Ecit [Pl

YWeb  Window Help

e :gmt op Layout

M = | i D Default —L[ J
Undock Command YWindow Command Window Only —
To 98t 31w Command Window E:imple M
e Command History %;iti'tigw
Current Directary —
\Workspace Eive Fanel
Launch Fad
Help
| LI
Ready
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R MATLAB II=] B3
File Edit “iew ‘Webh Window Help
N Ei?-| ¥ B o) o | % | ? |Currer|t Directary: [ d-WATLABEIork =l
Cornrmand History n | Cormrmand Wwindow
$--  4:09 PM 8/29/00 --% T =
To get started, select "MATLAE Help™ from t
=F
I~
1| | 3

Ready
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File Edit “iew “Web MWindow Help
@lﬁ’r | i B o ou | iy | ? |Current Directary: [ cMATLABEWork =] J

Cormmand YWindow

Cornrnand History k |

¥--  4:09 PM 5/29/00 --% [—
To get started, select "MATLAE Help™ from t
Jse the Arrow to undock the s
Command History window
fram the Deskiop.
3
1| | 2

Ready
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*.l' Command History M=l E3
file Edit Yew Weh Window Help
-- 4108 PM &/29/00 --%
irectary: [ o waTLABBAark ~] J
% the Help menu. —
Ready
1] [
Ready
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<} Command History Mi=]
File Edit Eiewr\Weg Window Help
$--  4:09 FM 8/23 N0 --%

IIze the View menu to dock the
Command History window back in

the Deskiop. lirectary: [ o MATL&BRW ok =] J

the Help menu.

Ready

-
1] [

Ready
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I [=] B3

+) Command History

File Edit Webh Window Help

$-— 4:08 1 Desktop Layout r
B and Histany

¥ Comrmand Window
v Cornrmand History irectory: | o MATLABEYOrk =] J
Current Directary =
Wiorkspace the Help menu.
Launch Fad
Helg

Ready

| =

Ready
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<} MATLAB =] E3
k- Edit “iew ‘Web ‘Window Help

0 E’,’,| ¥ B o G | iy | ? |Current Directary: | & MATLABGWork =l

Corrmand History n | Command Windows

3--  4:09 PM 5729700 --% (=
To get started, select

Or simply drag the
Command History to undock =
it frarm the Deskiop.

Click here and drag to move this window...

J Gadewadikar, Automation and Robotics Research Institute




The Society of Hispanic Professional Engineers

MATLAB TUTORIAL, March 26, 2004

+} Command History k
Edit “iew ‘Wek

F--  4:09 PM /29700 --%

ctary: | o A TLABE WYark

Ready

lhe Help menu.

Ready
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<) Command History I [=] E3

FEile  Edit Web Window  Help
e E  Destiop Layout Default =02
Dock Command Histary Cornmand YWindow Cnly
Simple TLABBark =l
¥ Command YWindow S% 1t Hist
¥ Command History =9 : Isionf —
; Tall Histary s
Current Directony Fivg P |
Wiorkspace Shisials
Launch Fad
Help
Ready
1 [
Ready
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Ei Edit “iew ‘Web ‘Window Help
O = | ¥ B o cx | 1] | ? |Current Directary: | o MaTLABEark =] J

n | Cormrmand Window
-

To get started, select "MATLAE Help™ from t—

{lCDntrDl Fysten Toolbox =l

R _>ILI

4| Pl Launch Pad I Yiorkspace |

Cornrmand History

(--  4:09% PM /29700 --%

Choose a tah for vour
desired Deskiop tool.

4 | B
4| » | .current Directory | 4| | 3

Click here and drag to maove this window...
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RJ'MATLAB
le  Edit Yiew ‘eb ‘Window

D@ | W Bl

Ilze the Close hutton to =] E3

close

the selected toal.

A

— AAiark =l

Launch Fad

R x
I _>I_I

Cornrmand Windomes

2

4| Pl Launch Pad I Yorkspace |

Current Directory

[amrLassvio | || @) ck | #4

411 files IFilE Type
@m}*data.mat MaT-file =

4 | oI

4! PI [CurrentDirectnw I

To get started, select "MATLAE Help™ from t—

Ready
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Ise the View menu to moaodify the
Deskiop configuration.

<} MATLAB
ile  Edit Miew. " Web Sindow Help

O & | < cu | g | 2 | curent Directory: [t wiaTLABE WOk

=

To get started, select "MATLAE Help™ from 1:—

3> |

J

4| Pl Launch Pad I YWorkspace |

| 4| VI Comrmand History [ Current Di

Ready
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MATLAB IS A MATRIX CALCULATOR !
MATTix + LABoratory = MATLAB

MATRICES
What is a matrix?
A matrix is a an arrangement of rows and columns,

Like this
1 2 3
A=|4 5 6
7 809

One can see that this has 3 rows and 3 columns i.e. it is a 3 by 3 matrix.
FOR MATLAB EVERYTHING IS A MATRIX,

Question: Is scalar number “5” a matrix for MATLAB?

Answer: Yes number “5” isa 1 by 1 matrix.

Creating a matrix is as easy as making a vector, using semicolons (;) to
separate the rows of a matrix.

If we type

A=[123;456;789];

Matlab will receive a matrix A in workspace.

If we do A+Enter MATLAB will give what is stored in “A”.

One area in which MATLAB excels is matrix computation.

We can easily find the transpose of the matrix 'A’.

B=A

Now let's multiply these two matrices together.

Note again that MATLAB doesn't require you to deal with matrices as a
collection of numbers. MATLAB knows when you are dealing with
matrices and adjusts your calculations accordingly.

C=A*B
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Let's find the inverse of a matrix ...
X =inv(A)

and then illustrate the fact that a matrix times its inverse is the identity
matrix.

I=inv(A)* A

MATLAB has functions for nearly every type of common matrix
calculation.

Some Basic Matrix Operations

First, let's create a simple vector with 9 elements called 'a’,
a=[123464345]

Now let's add 2 to each element of our vector, 'a’', and store the result in a
new vector.

Notice how MATLAB requires no special handling of vector or matrix

math.

b=a+2

J Gadewadikar, Automation and Robotics Research Institute
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Creating graphs in MATLAB is as easy as one command. Let's plot the
result of
our vector addition with grid lines.

plot(b)
grid on

J Figure No. 1 D@@

File Edit Wiew Insert Tools Window Help
DEeEdE A A/ 225
B T | T | | T
- N N W YU WO S
L Ty LTIy | o, L D I S S
A S S e
| SEES S e (e MR T e _
N N 4 O S N 20074 W
- nsereassaslome _-—
- BRIV Tk P SR
. A (. WO .
16 IO T W B
; I S S BN
1 2 3 4 5 B i g 8

MATLAB can make other graph types as well, with axis labels.
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bar(b)
xlabel('Sample #)
ylabel('Pounds')

-) Figure No. 1 E@

File Edit Wiew Insert Tools ‘Window Help

T DExEHE MNA AL B2 D

Pounds
=

Sample #

MATLAB can use symbols in plots as well. Here is an example using *'s to
mark
the points. MATLAB offers a variety of other symbols and line types.

plot(b,*")
axis([0 10 0 10])
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J Figure No. 1

File Edit Wiew Insert Tools Window  Help

DeEdE NA A/ 20

1 I:I T T T T T T T T T

gl -
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Importing Data:
How to import data into MATLAB?
1. Select Import data from the file menu and then select the file to
import.

D WIATLABR] 2Wrk o

lrnp.:u*[] ata..

Import

-

=] Masdag

Recoghized data files I

J Gadewadikar, Automation and Robotics Research Institute
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2 Import Wizard: D: /MATLABR12/Work/Nasdaq. txt

X

E

728321| 4071900 4101100
728322) 4099300 4125500
728325 412.5200) 4154200
The preview pane shows 728326 413.9900 413.9900
the format of the data 728327 4102200 4124400
within the file. 728328 411.7800)  411.7800
728320 4100500  410.0800
728332)  397.4800) 4001900
728333 3996200/ 4022400

et

J Gadewadikar, Automation and Robotics Research Institute
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XY Plots in MATLAB
% Line plot of a chirp
x=0:0.05:5;
y=sin(x."2);

plot(x,y);

J Figure No. 3 E|E”E

File Edit Wiew Insert Tools ‘Window Help

DEES NAA A/ HPHD
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% Stem plot

X =0:0.1:4;

y = sin(x.*2).*exp(-X);
stem(X,y)

I:|35 T T T T T T T

0.3

£
£

0.25

0.2 -

015

£

0.1

0.0

DG@TT T TTTT"F oFte

-0.05

el
—
o
€

O

3
o
=

H

0.1

e

_|:|15 | | 1 | | | |
a 0.5 1 15 2 245 3 358
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3 D Plots

figure;% Mesh Plot of Peaks
z=peaks(25);

mesh(z);

J Gadewadikar, Automation and Robotics Research Institute
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Simulink

type simulink

>>simulink

or click on this simulink block

-} MATLAB

File Edit Wew ‘Web ‘Window

Current Directory

| C:\MATLAB6pStwork vi[] B 4
411 Files File Twype Last Modifiec
|:|dti Folder 25-0ct-2003 0%
Dup%lriguyenﬂl Folder 25-0ct-2003 0 =
[:|TDTI:Il Folder 25-0ct-2003 0
4314demn.m M-file 05-Jun-1999 0
4343—1&:{.1]1 M-file 05-Jun-1999 0
hrusselatur.m M-file 30-Mar-2003 0
D.chal:usl.asv AZY File 09-dug-2003 0
u:hau:-sl.m M-file 09-Adug-2003 0
D.chansz.asv AZY File 09-fdug-2003 0
chansz.m M-file 09-dug-2003 0
dampﬂy. M-file 24-May-2003 0w
< ¥
Cur_rentDirectl:urg.f
Command Histary E| i
nargin(g) ~
margini-g)
Focor=-10%logll{alpha)
o w
4\ Start

Simulink Library Browser will open up
J Gadewadikar, Automation and Robotics Research Institute
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[ simulink Library Browser
File Edit Wiew Help

O & A Find |

Continuous: simulink/Continuous

= Tl Sirmulink
| Continuous
y Discontinuities %
y Discrete
# Look-Up Tables

[

Dizcontinuities

Higrin

#| Math Operations Discrete
2| Model Yerification
| Model-wWids Ukilities ol bl
# Ports & Subsystems =
3| signal attributes - :
; .g : I " b ath O perations
J Signal Routing m
# Sinks ®
#] Sources @ Model Yerification
L2
¥ User-Defined Functions
W@ Control System Toolbox || Mise Modelafide Lltilities
+- W Fixed-Paint Blockset
+ | Fuzzy Logic Toolbox _ & £ Ports & Subsystems
+)- Wbl Meural Metwork Blockset
- TR Real-Time Windows Target 4 Sigrial Atiiblies
¥ EJ Real-Time Workshop ]
+- W 5-function demos ) ]
i+ T SimPowerSystems - E Signal Houting
i+ W Sirmulink Extras b
==ml  Sinks
P i)
w
> o Sources =
]
wefibull | lsacNafined Frinctione 0

Ready
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[ Simulink Library Browser
File Edit Wiew Help

) & A Find |

Denvative: Mumencal dervative: duddt.

= B simulink
: : dusdt

y Continuou
y Disconkinuities
# Discrete
#1 Look-Up Tables
2| Math Operations
#| Maodel Verification
# Maodel-wide Utilities
#1| Ports & Subsystems
2+ signal Attributes
y Signal Rouking
# Sinks
y Sources
2 User-Defined Functions
B Control System Toolbaox
W Fixed-Point Blackset
] EJ Fuzzy Logic Toolbox
| EJ Meural Mebwork Blockset
. B Real-Time Windows Target
=+ W Real-Time Warkshop
- W@ 5-function demas
[+ EJ SimPowerSystems
- B simulink Extras

|.l'||—'-

| ntegrataor

¥ = PutBu

e e State-Space

Tranzfer Fon

Tranzport Delay

“ariable Tranzport Delay

B |B||%]-

(=12
Al

Zerm-Pole

Ready L
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[ Simulink Library Browser,
File Edit Wiew Help

Ol = A find |

Relational I]'peratm: .-’-'-.pp'lies the zelected relational operator tao the ifputs and outputs
the result. The top [or left] input corresponds to the first operand.

1

= W simulink [-l=_ b agritude-fngle to
- 1 Continuous ¢-7|  Complex
1| Discontinuities
] Discrete e b ath FLinction
2 Look-Up Tables T
- 1 Math Operations [“:”] b atrix Concatenation
#1| Model Verification
3] Model-Wide Utilities @ T

2 Parts & Subsystems

z Signal Attributes
Bl .g ] min kdirihd 2
#1 Signal Routing
E e i Falynornial
i sources OfFY =& ‘l'l
- ¥+ User-Defined Functions
BB Cortrol System Toolbos ® Product
i+ W Fixed-Point Blocksst
: i R
+ EJ Fuzzy Logic Toolbo Im? Fealimag ta Complex

i+ Tl Meural Metwark Blockset
B Real-Time Windows Target

- W@ Real-Time Workshop

+ W s-function demos

i+ W@ SimPowerSystems

v W] Sirulink Extras

&= Relational Operator

o Reshape

floor Rounding Function
—— Sign
1 Slider Gain

@ Sum v
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Sources
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[ simulink Library Browser
File Edit iew Help

O = Ha Find |

' BancLEimited White Moize: “White noize for continuous [z-domain) svstems. Band-
limited uzing zem-order-hiold.

= gl Sirulink . | =
m Conbinuous untitled.mat | From File
y Discontinuities
2—] Discrete E Ground
y Look-Up Tables
m Math Operations Inl

23| Model Yerification
# Model-Wide Utilities
# Parts & Subsystemns

#3 Signal Attributes _/ A
am|
m Signal Rouking B

Pulze Generatar

* Sinks
1 Sources
#3 User-Defined Functions
B8 Control System Toolboy
i+ W Fixed-Point Blockset

R andorn Murmber

Repeating Sequence

+- W Fuzzy Logic Toolbox b Signal Generatar
+ - T Meural Mebwork Blocksst

B8 Real-Time Windows Target E sival 1| Signal Builder
i+ W Real-Time Warkshop

+- W s-Function demos
+ E SimPowerSyskems
+ E Simulink, Extras

Sine 'Wave

i

W
I Step
M

[ rifarm Randam Murmber

Ready
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Some Sinks (Output Blocks)

[ simulink Library Browser
File Edit Wiew Help

O & <A Find |

[ﬁsﬁiay: '!]lumeric dizplay of input values.

= E Sirmulink
2—] Continuous
- y Discontinuities

| Diizplay

# Discrete ] Floating Scope
# Lock-Up Tables
#1| Math Operations Ot
- 2 Model Verification
# Model-wide Utilities E seme
] Parts & Subsystems
Signal Attributes . )
%I .g ; Stop Simulation
: y Signal Routing
*| Sinks
2" S CEs Terminator
#1 User-Defined Functions
B Control System Toolbe: untitled.mat| To File
+ - W Fixed-Paint Blockset [
+- T Fuzzy Logic Tookbo simout | To'Woarkspace
v B Meural Metwork Blockset [
B Real-Time windows Target ] v Graph
+ - B Real-Time Warkshop

+- B s-function demos
+ E] SimPowerSystems
+ E Simulink, Extras

One Simple simulink Model
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=1 untitled * E]
File Edit Wiew Simulabion Format  Tools  Help
O =S Xl & |N|:urma| LJ@ BRE
|
Scope
) .rdu.fdt—.rIZI
W
Sine Wawve Drerivative Scope
= o] ]
Scope?
4
Constant
Ready 100 lode4s

HOW TO EXPLORE IT MORE.

This tutorial uses standard MATLAB help and demos.
Simply type help and try instructions.

MATLAB Central file Exchange.

MATLAB downloads are at www.mathworks.com.

http://arri.uta.edu/acs/jyotirmay/gadewadikar.htm
Email : jyotir@arri.uta.edu

THANK YOU AND HAVE A GOOD TIME !
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